My game server is outdated meaning the game's maintainers released a new update including updated server-side files. How do I update the server I manage?
Example(s)
Self-explanatory...
Cause(s)
A game maintainer released an update for a game. Duh...
Solution(s)
NFO
Any game servers on NFO are automatically updated. There is unfortunately no way to trigger a manual update due to the fact that NFO uses hard links for their installations. You could attempt a full repair, but I doubt that will have any effect. If a few hours go by and the game server is still not updated, please open a ticket with NFO or contact a higher up.
To open a ticket with NFO, please log into the control panel. Click on your server identifier located on the far-left menu. Go to the "Help" tab. Left-click the "Open a new support request now" link.
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In games such as Pirates, Vikings, & Knights II, unfortunately the automatic updater is not detecting when an update is released. Therefore, you will likely have to open a ticket with NFO or contact a higher up. Things will get done quicker if you simply open up a ticket, though.
Pterodactyl (AKA GFL Panel)
@Xy_ has implemented an automatic updater into our control panel. However, some machines or server setups may not work with this. It's still in beta.
You are able to manually update your server. You can refer to this thread for more details. You can create a file named UPDATE (for general updates) or VALIDATE (for validated updates) in the root directory. Afterwards, you can restart the server. Additionally, if you have admin access (or know someone who has admin access), in the Pterodactyl AdminCP, you can go to the server's page and go to the Manage tab. On this tab, you can left-click "Reinstall server" to have it update as well (it won't delete any custom files).
If neither options work, please contact @Roy because there is likely something wrong with the back-end.
Additional Information
None.

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