Jump to content
 Share

Neiva

Neiva's Graphics / Framerate Thread

Recommended Posts

Posted  Edited by Neiva

(Updated July 2020)

HAVING TESTED REAL WORLD VS DEMO PERFORMANCE, IT'S NOT 100% ACCURATE. FROM FINDINGS AVERAGE FPS WAS ~15% DIFFERENCE AND 1% / 0.1% LOWS ~40%.

 

Hey,

 

Out of curiosity, I have benchmarked CS:GO ZE with demo's / Fraps as I was interested to see what kind of performance I was getting and if I could improve. Wanderers v5_2 was the main map I tested as I think it's a good balance of particles, boss fights and also general optimization. 

 

All results are used with an overclocked GTX 1070.

 

System; i7-3770k (16GB DDR3 @ 1600Mhz)

https://imgur.com/a/ElRGm8g - Benchmark results

 

(Updated) i7-9700k (16GB DDR4 @ 3000Mhz, CL15)

https://imgur.com/a/169wIUT - Benchmark results

 

As multiplayer is impossble to test consistantly, I feel as though low settings gives more fps and lower input lag. Having played around with screenshots and quality settings, the best comprimise in my opinion is;

 

Global Shadow Quality: Low (very low / low is pretty much the same)

Model / Texture Detail: High (ideally like CS:S, would want textures high and models would to be low... Why Valve)

Texture Streaming: Disabled

Effect Detail: Medium

Shader Detail: Medium (need those high quality gun models)

Boost Player Contrast: Disabled

Multicore Rendering: Enabled (MAKE SURE THIS IS ENABLED)

Multisampling Anti-Aliasing Mode: None (2x or 4x is nice to have but I feel a slight input lag when the framerate dips)

FXAA Anti-Aliasing: Disabled

Texture Filtering Mode: Anisotriopic 16X (zero performance difference)

 

Random notes that may help

-Close all background programs. If you want voice chat in the background (ie discord), use Ripcord instead as it's lightweight.

-Turning Windows to High Performance mode will help for DPC latency and mouse input latency. Ultimate Performance Mode isn't recommended.

-Turning Nvidia Power Mode to "Prefer-Maximum Performance" for CS:GO may help as the GPU may go into power saving states.

-Remove any "old" performance options you might have picked up as they may cause issues. Back up your config and start fresh, this may help fix performance issues.

-Windows 1809 and newer, enable game mode. This surpresses background tasks and allows the game to be the main focus. Older versions of game mode had some issues.

-For Ryzen users, look up what the "CCX" for your processor is as Core Affinity can help heaps so that the task doesn't bounce between cores / CCX's. ie Ryzen 3600 has 2 CCX's, 3 cores each. CS:GO uses 4 cores so for the 4th core, it has to travel between CCX adding latency. The Ryzen 3700 performance a lot better than the 3600 for CS:GO due to this issue. Approximately 13% performance impact.  In later Windows 10 versions, the Ryzen Scheduler has helped do this automatically.

-The latest few Nvidia Drivers have been great overall. (446.14)

-Windows 10 2004 update - Hardware Accelerated GPU Scheduling. I recommend turning this off as it may cause issues. This will be great for the future but currently nothing properly supports.

-Changing to 1600DPI and calculate your sensitivity for a better experience.

Edited by Neiva

 

 

Share this post


Link to post
Share on other sites


i have a i7-2600k @ 4.5 GHz and gtx 960 4GB and some weeks ago my fps dropped from 200+ to 40-60 in some 64 player situations. i then installed new drivers and set everything to low settings but that only gave me like 20 fps more.

I then tried out the command mat_queue_mode 2 in console that actually gave me another 20 fps more, you might wanna try that too

I'll reinstall windows soon so maybe i fix it that way.

Share this post


Link to post
Share on other sites


6 hours ago, donchill said:

i have a i7-2600k @ 4.5 GHz and gtx 960 4GB and some weeks ago my fps dropped from 200+ to 40-60 in some 64 player situations. i then installed new drivers and set everything to low settings but that only gave me like 20 fps more.

I then tried out the command mat_queue_mode 2 in console that actually gave me another 20 fps more, you might wanna try that too

I'll reinstall windows soon so maybe i fix it that way.

the drop around players is just because csgo is shit

you cant do much to make it better other than lowering settings/other fps boosts

Share this post


Link to post
Share on other sites


12 hours ago, donchill said:

i have a i7-2600k @ 4.5 GHz and gtx 960 4GB and some weeks ago my fps dropped from 200+ to 40-60 in some 64 player situations. i then installed new drivers and set everything to low settings but that only gave me like 20 fps more.

I then tried out the command mat_queue_mode 2 in console that actually gave me another 20 fps more, you might wanna try that too

I'll reinstall windows soon so maybe i fix it that way.

 

Any 64- player server will have drops regardless, but it's more CPU related. As seen here on ze_nuke, graphics settings didn't really matter but having a better / or faster CPU gave a higher framerate. (ze_nuke is a really compact map and players are heavily bunched together).

 

mat_queue_mode 2 is hit or miss. Default (-1) recognizes your system hardware and acts accordingly. (2) forces the multi-core mode. While in theory, they should give the same framerate, people have reported either getting better or worse. Personally I just leave that one as default as Valve have said in "fps boost guides" that the default settings are pretty well optimized by their team for maximum framerate.

 

Yeah, worth a shot reinstalling Windows. The rolling releases of Windows 10 always seem to bring some new issue and a fresh install fixes it.


 

 

Share this post


Link to post
Share on other sites


just testing my laptop that i usually used for collage with i7 6700HQ ( 2.60 GHz ), DDR4 8GB Ram and GTX 950M ( everything low and disabled except Texture and Shader remain Maximum settings )
launch option :
-novid
-nojoy
-language japanese
-high
-tickrate 128
-nod3d9ex
-dxlevel 80
+fps_max 0
-freq 60
-threads 4
+cl_forcepreload 1

in 64 player situation never get lower than 30 fps ( average fps got 40 ~ 70 fps ) even i turned off the !stopsound ( turning off stopsound make your game lagging / loss i think ). ( on Competitive most of the map got 100 ~ 160 fps )

and also try with Maximum settings ( except V-sync ofc ) still never get lower than 30fps ( but the average fps goes down to 35 ~ 60 fps ) even turned off the !stopsound. this only happened when i'm defend position, doorhug could be diffirent story. ( on Competitive got 80 ~ 130 fps )


tenor.gif

Share this post


Link to post
Share on other sites


On 11/20/2018 at 7:16 PM, Rune said:

just testing my laptop that i usually used for collage with i7 6700HQ ( 2.60 GHz ), DDR4 8GB Ram and GTX 950M ( everything low and disabled except Texture and Shader remain Maximum settings )
launch option :
-novid
-nojoy
-language japanese
-high
-tickrate 128
-nod3d9ex
-dxlevel 80
+fps_max 0
-freq 60
-threads 4
+cl_forcepreload 1

in 64 player situation never get lower than 30 fps ( average fps got 40 ~ 70 fps ) even i turned off the !stopsound ( turning off stopsound make your game lagging / loss i think ). ( on Competitive most of the map got 100 ~ 160 fps )

and also try with Maximum settings ( except V-sync ofc ) still never get lower than 30fps ( but the average fps goes down to 35 ~ 60 fps ) even turned off the !stopsound. this only happened when i'm defend position, doorhug could be diffirent story. ( on Competitive got 80 ~ 130 fps )

 

Most of those "more fps" commands are obsolete now. Best to just use default, as Valve themselves have stated this.

-high (not needed)

-tickrate 128 (not needed)

-nod3d9ex (debatable. Good if you alt-tab a lot)

-dxlevel 80 (Interesting you have to use that, keep that I guess)

+fps_max 0 (fps_max 999 is better apparently, but debatable. Also having unlocked framerate on a laptop will increase heat output a lot. Try 120 or something)

-freq 60 (not needed)

-threads 4 (not needed)

+cl_forcepreload 1 (only needed if you have game on a slow HDD)

 

Looking around, you should be getting 110-150 fps at Ultra Settings at 1080p.


 

 

Share this post


Link to post
Share on other sites


8 hours ago, Neiva said:

-tickrate 128 (not needed)

its for setting local server tickrate so it is if you need a 128 tick offline server

8 hours ago, Neiva said:

fps_max 999 is better apparently, but debatable

Lower fps_max = faster loading times

 

Share this post


Link to post
Share on other sites


4 hours ago, Malal said:

its for setting local server tickrate so it is if you need a 128 tick offline server

Lower fps_max = faster loading times

 

Yeah but what do you need 128tick servers for, unless you're offlining something ( ͡° ͜ʖ ͡°)

 

Yeah, definitely have a lower fps_max for laptops too. There's a debate between fps_max 0 and fps_max 999.


 

 

Share this post


Link to post
Share on other sites


2 hours ago, Neiva said:

Yeah but what do you need 128tick servers for, unless you're offlining something ( ͡° ͜ʖ ͡°)

For grenade line ups because cs:go is shit

most ze servers are 64 tick anyways so its pointless for laserfagging

2 hours ago, Neiva said:

There's a debate between fps_max 0 and fps_max 999.

theres nothing to debate

the best monitor wont benefit from 1000+ fps

you dont need more fps than that and fps_max 0 (any high fps_max value will but 0 the most) will cause loading times to be longer, its better to cap your fps at around 300-500 depending on your setup regardless for loading times as i mentioned

 

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...