Jump to content
  • CS:GO ZE CPU Usage Graphs Issue


    Roy
    • Start Date: 07/16/2018
      Completion Date: 08/26/2018
      Expected Completion Date: 08/12/2018
     Share

    CPU usage graphs for our CS:GO Zombie Escape server on our new NFO machine is tracking oddly. This is for server-specific graphs.

     

    Here is an example:

     

    23826eb4b8cee0.png

     

    This started occurring for CS:GO Zombie Escape after moving it to the temporary machine as well. Moving it to the new machine hasn't resolved the issue.

     

    I don't believe this was caused by any game updates (no game updates were launched at the time this started occurring).

     

    I am setting this to medium priority because this is one of our largest game servers and I cannot observe overall machine CPU usage (still wanting to remove one of our NFO machines in the future) until these CPU statistics start tracking accurately again.

     

    Thanks.

     

    This is a project moved from our old Technical Tasks database to the Projects database. Some sensitive information may have been cut out when moving to the public.


    Leader: Roy Members - Roy
    Progress - 100%
     Share


    User Feedback

    Recommended Comments

    7-16-18

    Note for when I make NFO ticket - Initial move was triggered on June 25th, 2018.


    Thanks.

     

    7-17-18

    NFO ticket created. Ticket content:

     

    Quote

    Hello,

     

    We are experiencing a strange issue with the CPU usage statistics on our `gflgoze` server. Ever since the server was moved to a temporary machine (caused by a PSU failure back in late June), the CPU usage has been spiking up and down. Here's an example:

     

    23826eb4b8cee0.png

     

    The server is constantly full. Therefore, the CPU usage should be consistent. There were no game updates around the time this started occurring as well and our other game servers do not have this issue. There were also no server-side changes (e.g. configuration, plugins, and so on).

     

    We have also moved this to a new permanent machine (E3-1275v6), but the issue is not resolved.

     

    Could somebody from NFO take a look at this?

     

    Thanks!

     

    Thanks.

     

    7-17-18

    Changed Task Progress to 50

     

    7-21-18

    Reply from NFO a few days ago:

     

    Quote

    Thanks for the information here. My immediate thought for what could be triggering this spike for peak CPU usage would be that this CPU for the machine may be turboing much higher than before, causing the usage % to increase.

     

    Prior to this, it appears the CPU was peaking consistently to a maximum of 140%. Overall CPU usage for the machine at that time appears to have averaged out to 40%, which will limit turbo speed across all cores. CPU usage for the replacement machine and your new permanent machine is average out to only 14-15%, leaving a lot more headroom for turboboost to dynamically increase the CPU clock. Our graphs measure CPU usage % based on the base block for the CPU, so any additional CPU used by the increased clock would account for increases in usage

     

    I apologize for the delay.

     

    Thanks.

    Link to comment
    Share on other sites

    I'm going to go ahead and close this project since the NFO employee explained why the graph is acting strangely. NFO has no intentions in changing the behavior of their graphs at this moment.

     

    There is a possibility I may open this project up again if we run into an issue where we absolutely require the CS:GO ZE CPU usage graph to be accurate.

     

    P.S. We have successfully got rid of the older NFO machine (project). Therefore, we no longer need to rely on the CS:GO ZE graph.

     

    Thanks.

    Link to comment
    Share on other sites


    Guest
    This is now closed for further comments

×
×
  • Create New...