Jump to content
Snoopy

Mouse Problems - Need help

Recommended Posts

Hi guys.

 

I'm having some trouble with my mouse and I'm completely confused by the whole situation. It's a Roccat Kone XTD which is about 2-3 years old. I'll explain why.

 

So my mouse, every so often, stops working on my (5 year old) laptop. Sometimes it works and sometimes It refuses to work in any USB slot. Recently it has just stopped working altogether. I have 3 USB slots, 1 for my mouse, 1 for a Bluetooth adaptor (For my speakers since my Audio input jack is fucked, long story) and 1 that is always free. They're all USB 2.0's. I have tried another, less technologically advanced mouse and it works for a bit, cuts out for about a second and then it carries on working. 

 

Now the bit that really does confuse me is that I put it into a USB slot that I know 100% is working (the one I use for my Bluetooth) and it doesn't work which would make it look like a dead mouse. I asked my father for some help and he said he thought it was just a dead mouse but when I put it into his PC it worked perfectly fine. There were no issues at all. It would work 100% of the time.

 

Does anyone have any advise on what could be causing this? I've opened up the Device Manager to see if there are any hardware issues but there seem to be done. Could this be a lack of power going to the USB slots? Or something more severe? Bah, I don't know. Can anyone offer some advise please?

 

Many thanks.


11f4263ab6c30a3489f8db3145340861.png

 

So everyone is listing their former stuff so I'll just be cool and list mine :3

 

Former @HackingPotato's White Knight and Boss Former TF2 Division Leader Former Community Advisor Former TF2 Technical Administrator Former TF2 Server Manager Former TF2 Trial Manager Former TF2 Admin Former TF2 Revivalist Former TF2 Player Former TF2 God Former Media Leaderish Former somewhat Media team person Former VIP Former Supporter Former Member Former TF2 Player Former Player

Share this post


Link to post
Share on other sites

Oyvey I have this issue as well at times and what I figured caused this was your mouse's USB is starting to either Frey in the cord or the contacts are filthy, to clean contacts (EVEN IF THEY DO NOT LOOK DIRTY FOLLOW THIS STEP)  get a small bit of rubbing/cleaning alcohol on a q-tip and gently clean the plug with either a side to side motion or if you feel brave put a bit more pressure on it and use a forward and backward motion (this way does have a minor chance of breaking the chip do at own risk)

 

If this does not fix your problem then it's a frayed cord, to test this just try getting it to work then slowly work your way down the cord, moving the cord much like you would using the mouse and see if it stops working (if this is the issue then you could try to splice it and fix it but in all honesty it's easier and less frustrating to just buy a new one)

 

 

Sorry for the lengthy reply but I do hope this helps

Share this post


Link to post
Share on other sites
Achievements

I assume you mean the contacts on my laptop  then? I'll give it a try. Thanks.


11f4263ab6c30a3489f8db3145340861.png

 

So everyone is listing their former stuff so I'll just be cool and list mine :3

 

Former @HackingPotato's White Knight and Boss Former TF2 Division Leader Former Community Advisor Former TF2 Technical Administrator Former TF2 Server Manager Former TF2 Trial Manager Former TF2 Admin Former TF2 Revivalist Former TF2 Player Former TF2 God Former Media Leaderish Former somewhat Media team person Former VIP Former Supporter Former Member Former TF2 Player Former Player

Share this post


Link to post
Share on other sites

25 minutes ago, Snoopy said:

I assume you mean the contacts on my laptop  then? I'll give it a try. Thanks.

I was referring to the ones on the mouse itself because you say everything else works in those ports 

Share this post


Link to post
Share on other sites
Achievements

2 minutes ago, Bouncing said:

I was referring to the ones on the mouse itself because you say everything else works in those ports 

 

Oh. Everything else does work in the ports but my mouse works perfectly fine on my fathers PC.


11f4263ab6c30a3489f8db3145340861.png

 

So everyone is listing their former stuff so I'll just be cool and list mine :3

 

Former @HackingPotato's White Knight and Boss Former TF2 Division Leader Former Community Advisor Former TF2 Technical Administrator Former TF2 Server Manager Former TF2 Trial Manager Former TF2 Admin Former TF2 Revivalist Former TF2 Player Former TF2 God Former Media Leaderish Former somewhat Media team person Former VIP Former Supporter Former Member Former TF2 Player Former Player

Share this post


Link to post
Share on other sites

30 minutes ago, Snoopy said:

 

Oh. Everything else does work in the ports but my mouse works perfectly fine on my fathers PC.

If it's just your computer it fucks up on try removing the mouse software and reinstall

Share this post


Link to post
Share on other sites
Achievements

Just now, Bouncing said:

If it's just your computer it fucks up on try removing the mouse software and reinstall

 

Already done that, hasn't changed a thing :/


11f4263ab6c30a3489f8db3145340861.png

 

So everyone is listing their former stuff so I'll just be cool and list mine :3

 

Former @HackingPotato's White Knight and Boss Former TF2 Division Leader Former Community Advisor Former TF2 Technical Administrator Former TF2 Server Manager Former TF2 Trial Manager Former TF2 Admin Former TF2 Revivalist Former TF2 Player Former TF2 God Former Media Leaderish Former somewhat Media team person Former VIP Former Supporter Former Member Former TF2 Player Former Player

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.

×
×
  • Create New...